GMC Terrain, Equinox, and SRX Forum banner
61 - 80 of 90 Posts

·
Registered
Joined
·
657 Posts
smooth78u said:
sorry you know black cap is on top of transmission I put very small hose in hole to check transmission fluid?
Never tried that.
Anyway, rbarrios is right, it should be red and since you have about 44,000 miles on it, probably getting dark.

If you are getting metal shavings on the tube, from the top that is not good.

You can drain it and fill it about 3 times and you will have almost all the fluid change out. When you drain it there is fluid still left in the torque converter. So drain and fill, drive for a week, drain and fill, drive for a week, and drain and fill.
I like Valvoline full synthetic dexron vi. Need dexron vi for the warranty.
If you choose to flush, don't go to the dealer. Go somewhere cheaper. Make sure their flush is simply pushing through the transmission fluid with more transmission fluid. Some will flush with a cleaning agent.... That is not advisable.
A flush will take about 12 quarts of fluid. You can pick it up at Wal-Mart and the shops will usually than just charge for the labor.
I would change out the transfer case and differential if you have AWD. Mine was nasty black at 58,000. Easy diy job. Amsoil severe gear was my choice on that but any decent synthetic is good.
 

·
Registered
Joined
·
435 Posts
New to the Nox said:
Never tried that.
Anyway, rbarrios is right, it should be red and since you have about 44,000 miles on it, probably getting dark.

If you are getting metal shavings on the tube, from the top that is not good.

You can drain it and fill it about 3 times and you will have almost all the fluid change out. When you drain it there is fluid still left in the torque converter. So drain and fill, drive for a week, drain and fill, drive for a week, and drain and fill.
I like Valvoline full synthetic dexron vi. Need dexron vi for the warranty.
If you choose to flush, don't go to the dealer. Go somewhere cheaper. Make sure their flush is simply pushing through the transmission fluid with more transmission fluid. Some will flush with a cleaning agent.... That is not advisable.
A flush will take about 12 quarts of fluid. You can pick it up at Wal-Mart and the shops will usually than just charge for the labor.
I would change out the transfer case and differential if you have AWD. Mine was nasty black at 58,000. Easy diy job. Amsoil severe gear was my choice on that but any decent synthetic is good.
Manuel says do a Transmission CHANGE, not Flush. They say Flush will actually harm it.
 

·
Registered
Joined
·
657 Posts
Yikes, that is $$$
Changing the fluid will not likely solve your issue. But it is good maintenance.

They will not be able to get this figured out until you have a check engine light and thus a code to work with.

Good luck and let us know when/if this ever gets resolved.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #70 ·
New to the Nox said:
Yikes, that is $$$
Changing the fluid will not likely solve your issue. But it is good maintenance.

They will not be able to get this figured out until you have a check engine light and thus a code to work with.

Good luck and let us know when/if this ever gets resolved.
will today dealership did a transmission flush yep still surging and I put old oem air filter help A Little not much.. mechanic told me let broke down olny way find out .i'm really try find problem but have no kind lucky, what about Camshaft Position Actuator Solenoid ? ,warranty get ready to end 2018
 

·
Registered
Joined
·
10,591 Posts
smooth78u said:
will today dealership did a transmission flush yep still surging and I put old oem air filter help
While I don't remember every post of this topic, when you said "I put my oem air filter..." Are you saying that you were running a oil-bath air filter ? If so, maybe you problems are caused by a dirty MAF sensor, and maybe you should try cleaning the MAF sensor.

If I misinterpreted your comment, then "nevermind".
 

·
Registered
Joined
·
657 Posts
I may have figured out your problem.
Although if you had a k&n filter on than RIT is right and that can get oil on the maf even after you have just cleaned it.

Anyway, if that is not the case than you may very well have an air intake leak. Surging at intersections and now a missfire at higher speeds.
Somethings just don't throw a cel code.

Check out this video.

https://www.google.com/url?sa=t&source=web&rct=j&url=https://m.youtube.com/watch%3Fv%3D9CPqbaSgcok&ved=0ahUKEwjv2IGyn5HSAhVs0oMKHd1bBUAQo7QBCB4wAg&usg=AFQjCNHFypLcnCyjtn85b3c7gZSBoyUfwg&sig2=waopJkuhnAHI0Bxu9NEr1g
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #73 ·
New to the Nox said:
I may have figured out your problem.
Although if you had a k&n filter on than RIT is right and that can get oil on the maf even after you have just cleaned it.

Anyway, if that is not the case than you may very well have an air intake leak. Surging at intersections and now a missfire at higher speeds.
Somethings just don't throw a cel code.

Check out this video.

https://www.google.com/url?sa=t&source=web&rct=j&url=https://m.youtube.com/watch%3Fv%3D9CPqbaSgcok&ved=0ahUKEwjv2IGyn5HSAhVs0oMKHd1bBUAQo7QBCB4wAg&usg=AFQjCNHFypLcnCyjtn85b3c7gZSBoyUfwg&sig2=waopJkuhnAHI0Bxu9NEr1g
I bought a new air filter from pep boys about year ago so i keep my original air filter oem put back in I noticemade different ya my old air filter kind drity not much
 

·
Registered
Joined
·
5,619 Posts
Did putting the OEM filter back in help?
 

·
Registered
Joined
·
657 Posts
smooth78u said:
to be honest ya.but surging still the not much like use to be. Air filter help alot
What brand of filter did get from pep boys?
So you put old filter back in and it helped?
The old filter was a little dirty but not bad?
Curious, was the filter from pep boys dirty or clean?
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #77 ·
New to the Nox said:
What brand of filter did get from pep boys?
So you put old filter back in and it helped?
The old filter was a little dirty but not bad?
Curious, was the filter from pep boys dirty or clean?
pep boys air filter. A3631 Wehn i take out was just lil diry.old oem air fiter was dirty not super dirty so i take myair compressor clean out
 

·
Registered
Joined
·
10,591 Posts
So, changing air filters - and nothing else - improved the engine surging. But, both air filters are somewhat dirty. Why not spend $10 and get another NEW filter, and try that out. Then, report back. If it is not running perfect, then it may be time to clean the MAF sensor. If you don't feel comfortable with that procedure, then bring it to an independent shop.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #79 ·
Rit said:
So, changing air filters - and nothing else - improved the engine surging. But, both air filters are somewhat dirty. Why not spend $10 and get another NEW filter, and try that out. Then, report back. If it is not running perfect, then it may be time to clean the .MAF sensor If you don't feel comfortable with that procedure, then bring it to an independent shop.
tomorrow I will clean MAF sensor should I going head change out map sensor and replacing both solenoids Valve ?
 

·
Registered
Joined
·
10,591 Posts
smooth78u said:
tomorrow I will clean MAF sensor should I going head change out map sensor and replacing both solenoids Valve ?
I would do the inexpensive/easy stuff 1st. I would 1st put in a new air filter and collect some data. It still not better, then I'd clean the MAP sensor.

Why are you thinking of replacing the solenoids ? Did you get a check engine light ?
 
61 - 80 of 90 Posts
Top