GMC Terrain, Equinox, and SRX Forum banner
41 - 60 of 90 Posts

·
Registered
Joined
·
10,591 Posts
smooth78u said:
will act up again after coming off inrerstate come to stop light after long trips do 75mph on highway . :shrug:
Back to the dealer before they forget your name.
 

·
Registered
Joined
·
657 Posts
What kind of gas mileage do you get?
Since this problem started, has there been rough idle or noise?
I can think of all kinds of possible causes... Including a bad high pressure fuel pump.
Without seeing some scan data, especially when the acting up occurs, we won't know for sure.
See if they have a scanner that they can attach and record and drive it home with it recording until the problem comes up? Just a thought.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #44 ·
New to the Nox said:
What kind of gas mileage do you get?
Since this problem started, has there been rough idle or noise?
I can think of all kinds of possible caus4 es... Including a bad high pressure fuel pump.
Without seeing some scan data, especially when the acting up occurs, we won't know for sure.
See if they have a scanner that they can attach and record and drive it home with it recording until the problem comes up? Just a thought.
i have to checking to see. .yes rough idle before new throttle body. No noise.i asking the.. I was unleaded premium in the summertime now I'm back using unleaded does that make it any difference? Soon as I stop using premium then that's when I noticed that my problems start act up
 

·
Registered
Joined
·
657 Posts
smooth78u said:
i have to checking to see. .yes rough idle before new throttle body. No noise.i asking the.. I was unleaded premium in the summertime now I'm back using unleaded does that make it any difference? Soon as I stop using premium then that's when I noticed that my problems start act up
Hmm, you are now throwing in another variable, summer and winter. So it started acting up when you went to regular in winter? How cold is your temperatures?
On second thought, temperature should not have anything to do with this since engine is warmed up after highway driving.
Octane level of your gasoline could be a big clue.
Higher octane simply prevents the fuel from predetination.
By the way, I am learning my own car. I only have some knowledge and Little experience lol😊
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #46 ·
New to the Nox said:
Hmm, you are now throwing in another variable, summer and winter. So it started acting up when you went to regular in winter? How cold is your temperatures?
On second thought, temperature should not have anything to do with this since engine is warmed up after highway driving.
Octane level of your gasoline could be a big clue.
Higher octane simply prevents the fuel from predetination.
By the way, I am learning my own car. I only have some knowledge and Little experience lol😊
so is it warms up and get off interstate bama start acting up . should go back using a premium see if that helps
 

·
Registered
Joined
·
657 Posts
smooth78u said:
so is it warms up and get off interstate bama start acting up . should go back using a premium see if that helps
Timing chain has also been a common problem, even for a 2013.
Do you check your oil levels and is it down?
If so, when was the last time you had an oil change. Oil consumption and timing chain issue tends to go hand in hand here.

I am having an issue with m 2011 2.4l.
Checked my compression and all 4 were rather high. Usually the problem is too low.
Anyway, very high compression is indicative of high carbon buildup. I started using high octane fuel and my car seems to be running smoother with better gas mileage.
However, running higher octane is expensive and will only cover up the problem.
My likely cause for the high carbon in the cylinders is that the previous owners drove mostly city and didn't take care of it. However, it could be something else.
I am figuring this out myself before giving$80 to a dealer to tell me nothing is wrong or I don't know.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #48 ·
New to the Nox said:
Timing chain has also been a common problem, even for a 2013.
Do you check your oil levels and is it down?
If so, when was the last time you had an oil change. Oil consumption and timing chain issue tends to go hand in hand here.

I am having an issue with m 2011 2.4l.
Checked my compression and all 4 were rather high. Usually the problem is too low.
Anyway, very high compression is indicative of high carbon buildup. I started using high octane fuel and my car seems to be running smoother with better gas mileage.
However, running higher octane is expensive and will only cover up the problem.
My likely cause for the high carbon in the cylinders is that the previous owners drove mostly city and didn't take care of it. However, it could be something else. Soon as I get off all work out check all that stuff this is something to be a headache with this car
I am figuring this out myself before giving$80 to a dealer to tell me nothing is wrong or I don't know.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #49 ·
The dealership told me about a week ago they want all my senses and all good / If you had to guess, what do you think may be wrong my car ? will I find a oil leak on top of valve cover to drive side on leak I have pic of it don't know how to post on here
 

·
Registered
Joined
·
657 Posts
smooth78u said:
Transmission fluid it is clear not red is good or bad and ::) has metal shaven
Usually, transmission fluid is pink/red. Transfer case fluid is clear.
Did you drain it or just looked at the fluid from the side fill plug?
Some metal shavings is normal, especially from initial break-in. Someone here can correct me on that.

I guess I am concerned that you drained the transfer case which is not far from the transmission 🤔
I don't know but maybe the fluid in the transmission is clear for the Equinox.

Anyway, black fluid is bad. Clear or pink is good.
 

·
Registered
Joined
·
5,203 Posts
Dexronv VI trans fluid is red.

As the miles add up- it becomes darker.

This is what 50,000 mile trans fluid looks like (dark)..

Drained my from similar 6 speed trans in my Traverse.



new fluid on left- 50,000 fluid on right.



Quantum on the Traverse forum- aprox 41,000 miles on his fluid.




and your trans should have the same drain bolt..

Traverse V6


Equinox V6-- same location.... the 4 cyl models should be similar.
 

·
Registered
Joined
·
657 Posts
smooth78u said:
okay .my Transmission fluid it is clear kind oil look .should i do a transmission flush or change
How are you checking the transmission fluid?
There is no transmission fluid dipstick so I am asking this to make sure you are actually looking at transmission fluid.
The only dipstick is for engine oil.

Something is not right here.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #56 ·
New to the Nox said:
How are you checking the transmission fluid?
There is no transmission fluid dipstick so I am asking this to make sure you are actually looking at transmission fluid.
The only dipstick is for engine oil.

Something is not right here.
put pvc hose in where black cap is . I then called my local dealer and they said that clear is normal hmm
 
41 - 60 of 90 Posts
Top