GMC Terrain, Equinox, and SRX Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I use my Android device for music a lot when I'm driving via USB. Never had a problem with it. I always leave my cable plugged in to the USB and just connect my phone as desired. Normally, when I connect the phone, it will auto switch the source to the USB from whatever I'm using (usually SXM.) When I disconnect my phone, it typically switches directly to FM. Within the last few days, when I connect, it only sometimes will switch to USB, but I only get as far as "Reading USB." Now, even with the phone disconnected AND the cable completely removed from the USB port, the USB button remains an active option on my "Source" screen and even with nothing connected says "Reading USB." Normally, the USB and Aux should be "grayed out" when nothing is connected to them. Any thoughts? Do I need to replace the port?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
After a 20 minute phone call to GM (mostly on hold), I was told that Android shouldn't work at all in GM vehicles. I've never had a problem. I think they were missing the part where the vehicle says it is "Reading USB" when NOTHING is connected to the USB port.
 

·
Registered
Joined
·
1,373 Posts
You know it - sometimes the support team are just nitwits.
Perhaps try pulling the fuse for the radio? Will that help reset the radio? (Or do you have the option to Reset to Factory Settings?)

I have inconsistent and quirky problems with Intellilink using a bluetooth connection. Wish GM would find better partners to develop this interface (which is nearly the most noticeable interaction with the passengers). :facepalm:
 

·
Registered
Joined
·
7 Posts
Same exact issue, just one month later and with an iPhone 6, so we know it's not device specific. Need to try with my other devices so that I have that trouble shooting out of the way when I go to dealer. Unfortunately, I am just out of warranty.
 

·
Registered
Joined
·
1,755 Posts
Mine will occasionally freeze up and stop playing music off the iPhone. I find it starts working again after the car is turned off for a few minutes. You need to leave it for a few minutes, because the car does not kill the power to the radio right away, even with the car off you having exited.
 

·
Registered
Joined
·
7 Posts
Tried that as it seemed to do the trick for awhile, but will only play audio for 7-10 seconds and then nothing. The audio continues on the device, but not through the system. Tried 3 different patch cables thinking it may have been a bad wire. The phone continues charging, just no audio and the constant "Reading USB device..."
 

·
Registered
Joined
·
1,755 Posts
Oh I think I've had that happen as well. But the problem did go away after a time. Have you tried doing a full reset on the phone (press the home and sleep button together till you see the apple)? Do you have a 128gb phone with a lot of music on it? How many tracks?
 

·
Registered
Joined
·
1,755 Posts
Ralphalph said:
Oh I think I've had that happen as well. But the problem did go away after a time. Have you tried doing a full reset on the phone (press the home and sleep button together till you see the apple)? Do you have a 128gb phone with a lot of music on it? How many tracks?
You might also try removing all the music from your phone. Attaching it to the car, seeing if the "Reading" message ever goes away. If it does, then go back and try to load some music on and try from there.
 

·
Registered
Joined
·
7 Posts
64gb phone. Not a lot of tracks. Maybe 100 or so. The "Reading USB" does not appear until after I toggle through the source screens and/or after I disconnect the device from the port. As I wrote above, the hookup works for 7-10 seconds with the correct display screen, then freezes both the sound and display on the OEM radio display.

Called OnStar to have them run a diagnostic on all systems and the rep said everything came back normal...OF course it did.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
And yes, the first thing I did was a hard reset of the phone. Sorry for not making that clear. The system always recognizes the device after restarting the vehicle, then it freezes after 7-10 seconds.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
So, I got home last night and plugged my daughter's 5c into the Terrain and everything worked just fine. So, that means it's a device issue, but I'm not sure why since as I wrote above that it worked as recently as last week. My next step will be to do a complete restore on my phone.

Still doesn't explain why the OEM radio gets stuck on the "Reading USB..." screen even after I disconnect my phone. It won't restore until after the car has been turned off without key in ignition.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Success! Deselected 'sync music' within iTunes and sync'd the phone removing all songs and the music library file. Then tested the phone and was able to remove it successfully after receiving the 'no files' message on the OEM touchscreen without it getting stuck on 'Reading USB...'

Then, re-selected 'sync music' to re-establish the music library file and songs. Plugged it into the USB port and everything worked, including song selection and streaming audio sources on the phone.

Thanks for reading about my ordeal and offering solutions. Hope this helps if anybody else is having similar issues.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Still have my legacy unlimited data, so I use the phone to stream pandora and out-of-town radio stations on long trips including my 2 1/2 hour daily commute.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1 Posts
Cant connect phone via usb

I just got a 2012 terrain, and it wont let me connect my phone to play music via usb. When i plug it up, it will sometimes say its trying to connect and i can see the album cover of the last think i listened to on spotify on the screen, but then it will say no audio files found. At one point, i was able to connect for a second and then it went away. i was on a chat thread with someone from gmc and they said they couldn't verify that music was able to be played by connecting via usb in my model...and it most definitely can
 

·
Registered
Joined
·
136 Posts
I just got a 2012 terrain, and it wont let me connect my phone to play music via usb. When i plug it up, it will sometimes say its trying to connect and i can see the album cover of the last think i listened to on spotify on the screen, but then it will say no audio files found. At one point, i was able to connect for a second and then it went away. i was on a chat thread with someone from gmc and they said they couldn't verify that music was able to be played by connecting via usb in my model...and it most definitely can
What model do you have? I can play a flash drive or files saved on my phone but i cant stream via usb.
 
1 - 17 of 17 Posts
Top