GMC Terrain, Equinox, and SRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
My wife's terrain has just started displaying the warning lights for the stabilitrac and the ABS. whenever she first starts driving the brakes flutter when you press them. they tend to work properly once you drive for a minute but the light never goes out and the problem occurs everytime you start out again. Any suggestions for what this might be? The pads and rotors are brand new. Saw somewhere that it might be the wheel hubs but I don't want to start tearing things apart on a wing and a prayer.
 

·
Registered
Joined
·
247 Posts
It sounds like when the brakes were done, maybe something happened with the harness that connects to the front brake. In order to narrow this down, you will need to deep scan the vehicle. As its a abs light thats on, you will probably have a C code or two and it will point the way to where the problem is. The stabiltrack light will go out when you have fixed the abs problem. If you take the vehicle to have it scannned at a parts store, make sure their scanner can read abs codes at the very least.
 

·
Registered
2011 Equinox 1LT V6 3.0L
Joined
·
3,806 Posts
I'm going through the same thing with my Nox right now. Mine is throwing ABS code "C0035" code (front wheel speed sensor) ... but I think it's actually a broken wheel hub magnetic ring (that the sensor "reads"). I've ordered the replacement hub (ACDelco "Gold") from RockAuto for ~$82. We'll see if that quiets the problem or if the sensor also needs to be replaced (~$35)
 
1 - 4 of 4 Posts
Top