GMC Terrain, Equinox, and SRX Forum banner
1 - 5 of 5 Posts

·
Registered
2011 equinox lt 3.0 liter
Joined
·
2 Posts
Discussion Starter · #1 ·
have 2011 equinox it will start perfectly several times and then will randomly not start, dash blanks out and no power to the starter, battery is good, load tested it, alternator is good, changed out starter, no change. It will sometimes start if i shift into neutral, or sometimes not then shift back into park and it will start, sometimes, boosting it does nothing so it for sure is not a voltage problem, im thinking it is maybe a neutral relay switch in the shifter ? anyone have any thing like this happen> gm says the relay is not available separately and would have to buy new shifter assy. :eek: started looking at youtube videos and removing the shifter is a fairly detailed job... looking for any advice on anyone that has same issues, im thinking im not the only one ...

experience and wisdom/ tips appreciated.

terry
 

·
Registered
2010 GMC Terrain - SLT - V6 - 225K Km's (~140K miles) - Gold Mist - Largely restored
Joined
·
37 Posts
Presumably, every time you touch the brake you can freely move the shifter? That at least eliminates the brake switch.

Dash blanking out as you go to start is normal.

Here's the starter circuit diagram.
(ok, it's attached!)

I would start by swapping the starter relay with something else (unless you have a few spares) that's not critical.
 

Attachments

·
Registered
2011 equinox lt 3.0 liter
Joined
·
2 Posts
Discussion Starter · #3 ·
Presumably, every time you touch the brake you can freely move the shifter? That at least eliminates the brake switch.

Dash blanking out as you go to start is normal.

Here's the starter circuit diagram.
(ok, it's attached!)

I would start by swapping the starter relay with something else (unless you have a few spares) that's not critical.
thank you - i will certainly check the circuit diagram, i was doing the same thing when it was working before the starter quit all together, a new starter seemed to fix the problem for about a week and now its intermitant, no codes are coming up, and my code reader is not showing any errors so im at a loss, also the starter celonoid for is not available separately, must buy the complete starter, but i will check for the relay,
 

·
Registered
2010 GMC Terrain - SLT - V6 - 225K Km's (~140K miles) - Gold Mist - Largely restored
Joined
·
37 Posts
If the relay is bad, it wouldnt set a code. Ecm knows it’s there (the coil half) since it activates it and it sees current draw. It has no real way of knowing if the switch contacts closed (sending power to the starter solenoid).
 

·
Registered
2010 GMC Terrain - SLT - V6 - 225K Km's (~140K miles) - Gold Mist - Largely restored
Joined
·
37 Posts
Another thought. Find someone with a good enough scan tool that it will tell you the shifter switch status.

it’s always possible that it’s bad and randomly telling the ecm that you’re not in park or neutral.
 
1 - 5 of 5 Posts
Top