GMC Terrain, Equinox, and SRX Forum banner

1 - 20 of 71 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I didn't see this topic in the Equinox section in this forum although it is discussed in the GMInsiderNews website forum. When I ran across this site, I thought it might be a good topic to include.

After a weekend trip from Michigan to NYC anc back in my 2010 4 cyl Equinox, I noticed on my way to work Monday morning that it was running a little rough. At stop lights, the RPM fluctuated down then up, almost like it was missing, but not quite. It revved up too high. When stepping on the gas to go, there was a hesitation. When I dropped my wife off at work, I noticed a rough idle sound from the exhaust and a lot of rotten egg odor. None of this was normal for my vehicle.

When I arrived at work and shut off the engine, it dieseled for about one second. Really wierd. After work, it started fine and drove fine until I got off the xway after 10 minutes and everything started to happen again. Then the check engine light came on. I stopped at AutoZone for a free trouble code check and it came back P0172 - too rich.

Dieseled to a stop at home, then Googled the trouble code and found the GM Inside News thread about a similar issue.

To shorten the story, I made some inquires to friends at GM and found that it is a problem with the high pressure fuel pump. A seal inside the pump can fail, allowing fuel to get into the oil. There was so much fuel mixed in with the oil, that when I shut off the car, oil in the cylinders ignited and caused the dieseling. It caused my oil to turn BLACK. You may be able to smell fuel in the oil.

The problem has happened before and GM is aware of it. Failure usually occurs on vehicles with under 6k miles. My vehicle just turned over 50k. The GM guy said they are very interested since they have not had a seal fail at high mileage. Probably because nobody else has 50k on their vehicle!

I dropped the car off at the dealer for repair under the 100,000 mile Powertrain warranty. They had to order the pump, but I get a free loaner until the job is done. Oil change is included in the repair.

A bonus is that my vehicle is one built with the ticking pump. Although the ticking has mostly gone away, the new pump includes the fix - and hopefully a better seal. So it should be quieter.

I could be waiting up to two weeks for a replacement pump.
 

·
Registered
Joined
·
468 Posts
Same error always happens to me when I take it on long drives. From NJ to SC happened, cleared itself, SC to NJ happened, cleared itself, NJ to FL happened, cleared itself FL to NJ happened, cleared itself. You got a more extreme happening of it though, it didnt alter performance and no rotten egg odor. The only other time I got that error and I wasn't on a long drive is when they were doing long term construction by my job and my air filter got clogged up faster then I care for it too.

54k on the clock
 

·
Registered
Joined
·
332 Posts
Ok I can understand a failure like this but there is one serious side effect to this that no one is considering and may take another 50K-100K to appear.

That side effect is operating the vehicle while gasoline is mixing with the oil and diluting it. Gasoline is a terrible lubricant and adding to your oil reduces it's lubricating properties.

So did you expose your engine to excessive wear during the driving you did which may only manifest itself after warranty has expired? Did it affect other seals in the engine? Did it cause some wear to the oil pump?
 

·
Registered
Joined
·
1,082 Posts
2010Nox said:
Ok I can understand a failure like this but there is one serious side effect to this that no one is considering and may take another 50K-100K to appear.

That side effect is operating the vehicle while gasoline is mixing with the oil and diluting it. Gasoline is a terrible lubricant and adding to your oil reduces it's lubricating properties.

So did you expose your engine to excessive wear during the driving you did which may only manifest itself after warranty has expired? Did it affect other seals in the engine? Did it cause some wear to the oil pump?
Which is why I use good, very good, synthetic oil. Direct injection engines are tougher on oil than any other, aside from turbo direct injection engines, than any other engine. The extra $10 is good insurance in my mind.
 

·
Registered
Joined
·
18 Posts
Just picked mine up yesterday from the exact same problem, 45000km and they could smell oil in the gas. Problem got worse when the dealer screwed up and ordered the worng pump, tried to install it, figured it was the wrong one, put the old one back in, broke the fuel line, forgot to mention to me the problem, and sent me on my way. After the massive headache from all the leaking gas, two weeks in the shop, hopefully this is one repair that they get right. Only half a dozen more problems and everything will be alright.
 

·
Registered
Joined
·
43 Posts
lurker18 said:
Just picked mine up yesterday from the exact same problem, 45000km and they could smell oil in the gas. Problem got worse when the dealer screwed up and ordered the worng pump, tried to install it, figured it was the wrong one, put the old one back in, broke the fuel line, forgot to mention to me the problem, and sent me on my way. After the massive headache from all the leaking gas, two weeks in the shop, hopefully this is one repair that they get right. Only half a dozen more problems and everything will be alright.
Sounds like your main problem is your dealer, not your vehicle.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #9 ·
2010Nox said:
So did you expose your engine to excessive wear during the driving you did which may only manifest itself after warranty has expired? Did it affect other seals in the engine? Did it cause some wear to the oil pump?
The dealer called me yesterday to say the fuel pump was finally in their hands (after 2 weeks and 2 days in the shop). But....the bad news is another Equinox with the same problem has cam damage probably from the gas in the oil. They want to look mine over before they give it back.

Today, I got word that the fuel pump is installed and all the parts are okay. However, the transmission seal they fixed is still leaking and they have to redo the seal.

So, I hope there is no hidden damage. Meanwhile, I'm still driving the loaner they gave me. An HHR. Pretty nice ride.

Maybe tomorrow, I'll have my car back!
 

·
Registered
Joined
·
18 Posts
Seems to be a fairly common problem. Both mine and the parents have had fuel pumps replaced, and the guy that handles the loaner cars guessed that was the problem when I picked up the loaner. He has had several come through the shop with the same thing.
Both ours and the parents were close to 40, 000 km when this happened.
 

·
Registered
Joined
·
1 Posts
I also have a 2010 4- cyl Equinox that I bought in June. It has had the same issue with the failed Fuel pump in Dec and now again this week. It is in the garage right now...so...I hope this next fuel pump does the trick. I also hope that I do not have problems in the future caused by the gas in the oil! Unfortunately I am told that it will take up to 2 weeks to get the part. It is nice to have a loaner car but that is not what I am making payments on! The issue all started around 28,000 km (17,500 miles)
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #13 ·
I had to wait 2 weeks for the HPFP even though it was ordered on priority. My Nox had 49950 miles on it. The dealer said it was covered under warranty and I didn't pay a penny. The dealer provided a loaner car for 2 weeks - also no charge. Dealer checked for internal part damage due to contaminated oil and verified there was none. All this is written on the service repair order so I'm covered for any future problem with it.

My Service Stabilitrak light also came on at the onset of the fuel in the oil/fuel pump problem. It has not come back on since I picked up the car, although there was a transmission seal leak which they found doing a routine inspection and fixed under warranty as well.

The car is running good again. Fuel economy seems about the same - 29MPG in winter. All in all, I'm satisfied with the way it turned out but perplexed that other owners are being treated differently.

A GM engineer that used to work on the 4cyl engine in my Nox emailed me and said he had not heard of any HPFP failures at 50k. Usually, it's before 6k.

It seems like there is a rash of them reported here. My dealer had another one in the shop after mine.

Good luck to others!
 

·
Registered
Joined
·
1 Posts
Hey guys, new on here. Looks like I might be on the same boat. 62K miles and having the same issue. Rough idle and the car buckles for a few seconds after I switch it off. Yesterday, while spring at a light it idled so rough triggering the check stabilitrak system. cleared up after I switched off the engine and restarted. would this be covered under warranty? Sounds very similar to the problems you guys have experienced in the past...
 

·
Registered
Joined
·
2,772 Posts
Lansal15 said:
Hey guys, new on here. Looks like I might be on the same boat. 62K miles and having the same issue. Rough idle and the car buckles for a few seconds after I switch it off. Yesterday, while spring at a light it idled so rough triggering the check stabilitrak system. cleared up after I switched off the engine and restarted. would this be covered under warranty? Sounds very similar to the problems you guys have experienced in the past...
I would recommend contacting your local dealer for more assistance. I can also look into this with your VIN. Please feel free to contact me directly. Thank you.

Tricia, GM Customer Service.
 

·
Registered
Joined
·
5 Posts
Hi All I'm new also here and just dropped my car off at the dealer for the same reasons, Rough idle at a stop light then check engine comes on then sometimes stabli trac warning. Sometimes when i shut off the car it runs for several seconds. Thenthe problem goes away for days even weeks then check engine light again. This started to happen around 55,000 miles give or take a few. Its sad because i love the case and at 28.2mpg right now it has been great. I'm just hope its covered under warranty because money is real tight right now before the holidays.
 

·
Registered
Joined
·
10,522 Posts
Mizer said:
Hi All I'm new also here and just dropped my car off at the dealer for the same reasons, Rough idle at a stop light then check engine comes on then sometimes stabli trac warning. Sometimes when i shut off the car it runs for several seconds. Thenthe problem goes away for days even weeks then check engine light again. This started to happen around 55,000 miles give or take a few. Its sad because i love the case and at 28.2mpg right now it has been great. I'm just hope its covered under warranty because money is real tight right now before the holidays.
If this is not covered, I would recommend that you do some searching on the forum.. This has been a generic problem, so you can point it out to your dealer, and then maybe they will cover it.
 

·
Registered
Joined
·
5 Posts
I just reveived a call from the dealer and they said it was covered under the powertrain part of the warranty so :cheers:
 

·
Registered
Joined
·
338 Posts
Mizer said:
I just reveived a call from the dealer and they said it was covered under the powertrain part of the warranty so :cheers:
:cheers:
 

·
Registered
Joined
·
2,772 Posts
Mizer said:
Hi All I'm new also here and just dropped my car off at the dealer for the same reasons, Rough idle at a stop light then check engine comes on then sometimes stabli trac warning. Sometimes when i shut off the car it runs for several seconds. Thenthe problem goes away for days even weeks then check engine light again. This started to happen around 55,000 miles give or take a few. Its sad because i love the case and at 28.2mpg right now it has been great. I'm just hope its covered under warranty because money is real tight right now before the holidays.
I am glad to hear that your and the dealer are working together to have your concern resolved. Please feel free to contact me with any questions or concerns in the meantime. Thank you.

Tricia, GM Customer Service.
 
1 - 20 of 71 Posts
Top