GMC Terrain, Equinox, and SRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
temp gauge shows normal reading after reasonable warmup time. blows hot air by your feet as directed. after 25 min drive gauge is still up,but air is cold. like its getting too much outside air. having trouble finding service info on heating system
 

·
Registered
Joined
·
119 Posts
temp gauge shows normal reading after reasonable warmup time. blows hot air by your feet as directed. after 25 min drive gauge is still up,but air is cold. like its getting too much outside air. having trouble finding service info on heating system

First, have compression check done to make sure you're not seeing the signs of a possibly eminent head gasket failure. If not, follow the steps I have posted here....




http://www.equinoxforum.net/29-1st-gen-equinox/17730-ridding-your-coolant-system-air-pockets.html


Hope this helps.


Starflare5.
 

·
Registered
Joined
·
3,503 Posts

·
Registered
Joined
·
119 Posts
On the step where you say to add coolant (or water) to the reservoir while watching for it to flow out the bleeder hole, should you also add something like, “ensure that you do not fill the reservoir beyond the HOT line?”

I can just see some people filling the tank all the way to the top ...
Technically, for this, you can fill the tank to the top because you're going to be bleeding out some from the system anyway..... Otherwise, with a healthy coolant system, it will simply go out the overflow tube.
 
1 - 5 of 5 Posts
Top