GMC Terrain, Equinox, and SRX Forum banner
1 - 3 of 3 Posts

·
Registered
2008 Equinox LS AWD Summit white, 2007 Torrent GT FWD Jet Black, 05 Pursuit 2.2L Titanium Metallic
Joined
·
41 Posts
Discussion Starter · #1 ·
For the past few months, my 08 3.4 LS has been shifting funny, or so I think. From first to second, and second to third, as I climb up in RPM's, right before it upshifts, the rpms go up as if I'm blipping the throttle, then shifts into the next gear. I mainly notice it when I'm on a slight incline but it has happened on any level/grade, and doesn't matter if the transmission or ambient temp is hot or cold.

I should note that about 5 months ago, I did have the transfer case replaced. It was making a horrendous rattling noise and was not drive-able. Also had the driveshaft removed, since the shop that did the repair said the hanger bearing was shot, which it was. Super mad about that because the previous owner had it replaced at 226,000, and these stupid things aren't cheap. (Real shame because I bought this as a winter car). Had the transfer case replaced at 292,000km's. I did disable AWD by pulling the fuse, and the car doesn't send power through AWD. I put the fuse back in, same thing. Car is now FWD and since it's summer, I'm not so concerned about loosing AWD.

In addition to that, transmission cooler lines were repaired by using high pressure hose and filling with the correct fluid. I check it every second oil change, since it's a PITA. It hasn't leaked since. Currently throwing codes P0401- bad EGR valve, and P0455- Large evap leak- fuel filler neck. History code P1779. The trans did the same thing today to me, but I cleared the DTC's yesterday and the CEL hasn't re-appeared. (The p1779 was stored prior to me clearing it btw). I replaced about a third to half the fluid when I replaced the lines, but that was 45,000 Km's ago when I first purchased the car.

Anyone have any experience with this? Is the trans done? Honestly, I paid $750 for this car three years ago and have done the head gasket (which is why i bought the car), brakes, ball joints, heater core, trans cooler lines and basic maint. Just recently did an alternator due to a bad bearing. IF this means the car is done for I have gotten my moneys worth over the past three years and I am totally happy with that. Plus ive got parts for days for my mom's 07 torrent- always a plus:cool:
 

·
Registered
2005 Chevrolet Equinox LT
Joined
·
32 Posts
I fix a lot of the Aisin AF33-5 (AW55-50/51SN) Transmissions.

Main issues with those are the Valve Bodys, they become clogged inside of them; and starts to slip, shift wrong, and even don't shift at all. Also, using other Dexron (or other ATF) instead of the specified T-IV will cause this and even complete transmission damage.

Check the ATF level, and change it for the T-IV, and see if that help. If not, most likely it requires Transmission Overhaul.
 

·
Registered
2008 Equinox LS AWD Summit white, 2007 Torrent GT FWD Jet Black, 05 Pursuit 2.2L Titanium Metallic
Joined
·
41 Posts
Discussion Starter · #3 ·
I fix a lot of the Aisin AF33-5 (AW55-50/51SN) Transmissions.

Main issues with those are the Valve Bodys, they become clogged inside of them; and starts to slip, shift wrong, and even don't shift at all. Also, using other Dexron (or other ATF) instead of the specified T-IV will cause this and even complete transmission damage.

Check the ATF level, and change it for the T-IV, and see if that help. If not, most likely it requires Transmission Overhaul.
I didn't use GM dexron, I think it was toyota? fluid. I was a service writer at Canadian tire and pulled up the recommended fluid and it said use fluid X and that's what i had put in. Don't actually remember if it said toyota, but I knew it wasn't GM fluid which didn't surprise me. I just changed the oil, but the previous oil change was done by a shop, and a reputable one at that. They service my works fleet of F150's and they do good work, and they said it was perfect level, and I left a bottle of that fluid in the car and asked them to use that if necessary. I took it in earlier this week to have a tire repaired and i asked them about that and they said that's probably whats going on with it, and told me to check the fluid and just drive it. The front subframes starting to rot, "Becoming religious and Holy" as the mechanic told me. At almost 300K kms I cant complain if the trans is starting to fail. I got the car for dirt cheap and beat the crap out of it on construction sites, as I install insulation in new homes. I am not overhauling or paying someone to overhaul it, the car doesn't owe me anything. I bought it as a learning tool and a winter beater.
Thanks for your input.
 
1 - 3 of 3 Posts
Top