GMC Terrain, Equinox, and SRX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hi all im new here i have an 05 equinox that has trouble starting when at normal temp acts like a fuel pressure regulator issue like with the v8's but the equinox has none. im a mechanic but am unsure what is causing this ive checked various things with no avail any help appreciated thanks
 

·
Super Moderator
Joined
·
931 Posts
....I have a feeling that there are not many Equinox owners here that own that generation. Mostly 2010 and up.
 

·
Registered
Joined
·
17 Posts
I had a 2005 Equinox LT AWD prior to buying my 2010 Terrain and I had this problem also. I had it to the local Chevy garage a number of times and on the last visit they said they had a fix. They replaced the fuel pump. I believe on this vehicle it is located inside the fuel tank. It didn't completely solve the problem, but it did improve the number of times it did it. Also, when starting the vehicle turn the key to the on postion for 3 to 5 seconds before you turn it all the way to the start position. This also helped. Good Luck!
 

·
Registered
Joined
·
1 Posts
My wife's 05 Nox has the same issue. It's been doing it for along time. Started at 30k. Finally at 43k I told the dealer. They did a fuel injector cleaning. Problem went away and came back at 68k. Just had it done again and it's fine. The. Dealer said it's from crap gas. My wife continues to put saws gas in.
 

·
Registered
Joined
·
2,772 Posts
Gqjonb77 said:
My wife's 05 Nox has the same issue. It's been doing it for along time. Started at 30k. Finally at 43k I told the dealer. They did a fuel injector cleaning. Problem went away and came back at 68k. Just had it done again and it's fine. The. Dealer said it's from crap gas. My wife continues to put saws gas in.
I am glad to see that your issue has been resolved. If you have any futher questions or concerns, please feel free to contact me via private message. Thank you.

Tricia, GM Customer Service.
 
1 - 6 of 6 Posts
Top