TerrainForum.net: GMC Terrain Forum - Reply to Topic
Thread: Just bought a rebuilt terrain. Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
11-27-2019 08:21 AM
Rotwiler Thanks. Gets frustrating.
11-25-2019 08:00 AM
Colt Hero
Quote:
Originally Posted by Rotwiler View Post
Odd, I have a lot of issues using this forum on my phone. Tried mobile view, non mobile, desktop etc, right now I can't find the edit to remove the double post but everything else is there. Once I posted this, Edit returned, but I can only edit this actual post, not previous ones since no edit is available.
They give you something like 24 hours to edit a post, then it’s locked and you have to ask an “admin” for help. Send a Private Message (PM) to “admin” AND “admin2” to get the duplicate removed.

Also - I used the “Mobile Enhanced” version on my iPhone (because it’s a little faster and easier to read), but you can’t “Like” posts. Have to switch to the “Full” version to do that.
11-25-2019 07:27 AM
Rotwiler Odd, I have a lot of issues using this forum on my phone. Tried mobile view, non mobile, desktop etc, right now I can't find the edit to remove the double post but everything else is there. Bonus on the Terrain I found out it has a active xm account, will see I guess how long that lasts. ( Once I posted this, Edit returned, but I can only edit this actual post, not previous ones since no edit is available.
11-14-2019 05:19 PM
Rotwiler Have put around 1,000 miles on it since I did the misc things like 02 sensor, cleaning tb, vvt sensors etc and zero check engine light. So that's fixed. Today drained the transmission and decided if it is black and burned smelling will get a service at a shop. So drained it and was not bad, still smelled fine(the Terrain has 54,xxx miles, fluid was darker but not what I expected it to be, was much better. So I filled with fresh valvoline synthetic fluid and will drain again around every 10k.since I have a case of havoline synthetic, after a couple changes should be good. Magnet on drain had zero metal, I couldn't see anything, actually was Shiney like stainless steel, I expected to see something on it. All that's left now is the differentials and I have mobile 1 75w90. Oil was at 50% life when I bought the Terrain, is down now to around 20%, zero oil use and is still clear and smells like fresh oil. So happy with everything so far.
11-14-2019 05:18 PM
Rotwiler Have put around 1,000 miles on it since I did the misc things like 02 sensor, cleaning tb, vvt sensors etc and zero check engine light. So that's fixed. Today drained the transmission and decided if it is black and burned smelling will get a service at a shop. So drained it and was not bad, still smelled fine(the Terrain has 54,xxx miles, fluid was darker but not what I expected it to be, was much better. So I filled with fresh valvoline synthetic fluid and will drain again around every 10k.since I have a case of havoline synthetic, after a couple changes should be good. Magnet on drain had zero metal, I couldn't see anything, actually was Shiney like stainless steel, I expected to see something on it. All that's left now is the differentials and I have mobile 1 75w90. Oil was at 50% life when I bought the Terrain, is down now to around 20%, zero oil use and is still clear and smells like fresh oil. So happy with everything do far.
11-11-2019 08:53 PM
bigb12359

How about just enjoy helping out where I think I can.
11-11-2019 01:10 PM
JayTee2014
Quote:
Originally Posted by RIT333 View Post
Bigb - how do you know so much about these vehicles? Are you a tech ? What is your background ? Thx

Big B is a superb and knowledgeable tech for sure . .
11-11-2019 12:13 PM
RIT333 Bigb - how do you know so much about these vehicles? Are you a tech ? What is your background ? Thx
11-11-2019 11:54 AM
bigb12359 The engine control module (ECM) controls a Closed Loop air/fuel metering system in order to provide the best possible combination of driveability, fuel economy, and emission control. The ECM monitors the heated oxygen sensor (HO2S) signal voltage, and adjusts the fuel delivery based on the signal voltage while in Closed Loop. A change made to the fuel delivery changes the long and short term fuel trim values. The short term fuel trim values change rapidly in response to the HO2S signal voltages. These changes fine tune the engine fueling. The long term fueltrim values change in response to trends in the short term fuel trim The long term fuel trim makes coarse adjustments to fuel ingin order to re-center and restore control to short term fuel trim. The ideal fuel trim values are around 0 %. A positive fueltrim value indicates that the ECM is adding fuel in order to compensate for a lean condition. A negative fuel trim value indicates that the ECM is reducing the amount of fuel in order to compensate for a rich condition.
11-10-2019 11:44 PM
Rotwiler
Quote:
Originally Posted by rednox301 View Post
I had a good chuckle on your post.
Reminds me of the old days, we used to keep Holley bowl gaskets and a screwdriver and a couple of wrenches in the glove box.

Took about 15 minutes to change both of them on the side of the road when they started leaking.
And they always did.
I'm 53, so been through the carb leaking lol maybe old ways never go away. Put a lot of miles now since I did the various things to the 2.4 and zero cel, so happy about that. Now the drive train fluids are next and will be good. Had it at friend's house on lift so I could check out damage it had in past, at dealer could only see some. Happy to say nothing looked bad, rear looked like was hit in lower center, they pounded out spare tire well and redid the muffler(cut 6 inch portion out of exhaust, cut inlet on muffler and re welded new section, a couple lower brackets replaced and bumper cover. Looked very good actually, and happy with the purchase. At $7,000 think it was good deal, even more now since I could get up in there and see it better. So far put around 1,800 miles on it since I bought it and haven't had to add any oil.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome