2011 Terrain question Someone help please - TerrainForum.net: GMC Terrain Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 12-06-2019, 03:22 AM Thread Starter
Jr. Member
 
Join Date: Dec 2019
Posts: 7
Exclamation 2011 Terrain question Someone help please

Hear whining sound only when the heater is on.
I have a 2011 GMC Terrain I'm hearing a whining noise that starts slow and increases in volume only when the HVAC is on, then stops for 2 to 3 min then comes back again and does the same things all of the time only while the heater is on. When you turn the heater off sounds stop. It sounds like the engine or transmission but as I said when I turn off the heater the sound stops. Any suggestions?

Last edited by mick1971; 12-06-2019 at 04:27 AM.
mick1971 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-06-2019, 12:36 PM
Theta Guru
 
Join Date: Dec 2010
Posts: 4,923
sounds more like an actuator moving to a certain spot--- and air getting past a narrowed path-- and whistling...


try lowering the air speed--- and see if the sound pitch changes.

2013 Equinox LT1 3.6L V6 FWD 88,000
2010 Traverse LT1 3.6L V6 FWD 153,000
2003 Trailblazer LS 4.2L I6 RWD 181,000
rbarrios is offline  
post #3 of 5 (permalink) Old 12-06-2019, 01:14 PM Thread Starter
Jr. Member
 
Join Date: Dec 2019
Posts: 7
I changed the actuator on the passenger side. When I lower the airspeed still can hear for it. It is weird comes when HVAC is ON for a 30 sec then despair for 2 to 3 min and the comes back again and repeating like that. When I turn heater OFF stops. Any more suggestions? Could it be an air motor blower ??
mick1971 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 12-06-2019, 01:33 PM
Theta Guru
 
Join Date: Dec 2010
Posts: 4,923
is this a digital AC model-- that is set a temp-- and forget it?


vs a manual one where you set it.

2013 Equinox LT1 3.6L V6 FWD 88,000
2010 Traverse LT1 3.6L V6 FWD 153,000
2003 Trailblazer LS 4.2L I6 RWD 181,000
rbarrios is offline  
post #5 of 5 (permalink) Old 12-06-2019, 03:32 PM Thread Starter
Jr. Member
 
Join Date: Dec 2019
Posts: 7
yes, it is, but I think I figure out where it is coming from. When clutch engage in AC compressor and starts to turn the kind of small squeaking noise coming, but I read when the clatch engages it is normal to hear kind of click and small squeaking Maybe, after all, is my imaginations ??
mick1971 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome