Camshaft Positon Sensors ('10 V6 3.0) - TerrainForum.net: GMC Terrain Forum
 1Likes
  • 1 Post By spook
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 05-31-2019, 01:47 PM Thread Starter
Full Member
 
woulddug's Avatar
 
Join Date: Aug 2017
Posts: 232
Garage
Camshaft Positon Sensors ('10 V6 3.0)

So engine light came on
parts store said need to replace Camshaft Position Sensors Bank 1 & 2


1) Are there 2 sensors o 4 sensors?
2) anyone have a link to a video of location?


I Googled and cant find anything good for a 3.0 V6 (2010)


I got a quote for a local shop for $500 and they said there are 4 of them?? Parts I find are $25-30 each, but also cant find any in stock
woulddug is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-31-2019, 02:40 PM
Theta Freak
 
Join Date: Mar 2011
Posts: 1,161
424 12626012 00.736 valve, cm/shf posn actr sol l (lf1) 2010 - 2010 04 6x 1 x0408

part number 12626012 valve. Is no longer serviced and is replaced by valve part number 12636175.
bigb12359 is offline  
post #3 of 9 (permalink) Old 05-31-2019, 02:42 PM
Theta Freak
 
Join Date: Mar 2011
Posts: 1,161


tried to post pic but cant .

looks to be in front engine cover
bigb12359 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 05-31-2019, 02:46 PM Thread Starter
Full Member
 
woulddug's Avatar
 
Join Date: Aug 2017
Posts: 232
Garage
??




Quote:
Originally Posted by bigb12359 View Post
424 12626012 00.736 valve, cm/shf posn actr sol l (lf1) 2010 - 2010 04 6x 1 x0408

part number 12626012 valve. Is no longer serviced and is replaced by valve part number 12636175.
woulddug is offline  
post #5 of 9 (permalink) Old 05-31-2019, 02:47 PM
Theta Freak
 
Join Date: Mar 2011
Posts: 1,161
# 12684186

421 12684186 02.383 SENSOR, CM/SHF POSN (INCLS 422) (PART OF 406) (ACDelco #12684186) LH,LJ (LF1) 2010 - 2010 04 12F 3600A

newest #
bigb12359 is offline  
post #6 of 9 (permalink) Old 05-31-2019, 02:56 PM
Full Member
 
Join Date: Nov 2018
Posts: 182
Quote:
Originally Posted by woulddug View Post
So engine light came on
parts store said need to replace Camshaft Position Sensors Bank 1 & 2


1) Are there 2 sensors o 4 sensors?
2) anyone have a link to a video of location?


I Googled and cant find anything good for a 3.0 V6 (2010)


I got a quote for a local shop for $500 and they said there are 4 of them?? Parts I find are $25-30 each, but also cant find any in stock
What was the specific DTC. You should have four, two per bank, one for intake and the other for exhaust cams.

I am skeptical that multiple sensors encountered an error due to failure. I would have a competent facility look at the crank sensor as a cause, or possible chain slip.

Are you experiencing any driveability or performance issues when this occurred.
sydnesb is offline  
post #7 of 9 (permalink) Old 05-31-2019, 03:13 PM Thread Starter
Full Member
 
woulddug's Avatar
 
Join Date: Aug 2017
Posts: 232
Garage
2 weeks ago I had to change EVAP Purge Valve
Since then my gas mileage has increased 2.4mpg


I do feel a LITTLE (Very Little) idle fluctuation but nothing else. Yesterday I was driving in Heavy City traffic and engine light came on
Took it to arts store and they scanned it, and told me Cam Position Sensors on Bank 1 and 2 needed replacing






Quote:
Originally Posted by sydnesb View Post
What was the specific DTC. You should have four, two per bank, one for intake and the other for exhaust cams.

I am skeptical that multiple sensors encountered an error due to failure. I would have a competent facility look at the crank sensor as a cause, or possible chain slip.

Are you experiencing any driveability or performance issues when this occurred.
woulddug is offline  
post #8 of 9 (permalink) Old 05-31-2019, 10:33 PM
Theta Guru
 
Join Date: Feb 2011
Posts: 3,287
I’m not near my Helm Manuals, but IIRC there are 4 sensors and they’re pretty easy to replace - right on the belt side of the engine?

Do you see their electrical connectors?

2011 Equinox 1LT (new Jan 2011): Summit White / 3.0 L V6 / FWD / Pioneer Stereo / 18" Wheels / 138.2k miles [05-NOV-2019]

2002 Impala 1LT (new Jun 2002): Summit White / 3.4 L V6 / FWD / Cassette-CD Combo /225.5k miles [05-NOV-2019]
Colt Hero is offline  
post #9 of 9 (permalink) Old 05-31-2019, 11:28 PM
Sr. Member
 
Join Date: Aug 2011
Posts: 491
This may help you with the installation

https://workshop-manuals.com/chevrol...ews/page_3131/

Rock Auto sells these sensors for significantly less than what you were quoted see this screenshot/

S
Attached Images
File Type: png Screenshot (10).png (167.5 KB, 9 views)
Colt Hero likes this.
spook is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome