shift issue, 2010 terrain - TerrainForum.net: GMC Terrain Forum
 3Likes
  • 2 Post By rbarrios
  • 1 Post By rednox301
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 11-19-2019, 11:17 AM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 3
shift issue, 2010 terrain

my wife's terrain wont shift after 30 to 40 mph..a couple times she was able to turn it off and back on and it worked fine, but today no dice...
any ideas ? I have my buddy at a chevy dealer pricing me a trans and a TCM...just to be ready...
Partzman09 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-19-2019, 01:55 PM
Theta Guru
 
Join Date: Dec 2010
Posts: 4,908
That she was able to turn it on/off...
I think this may be an easier repair-- with a new TECHM.... or replacing the solenoid shift discs that tend to tear- and cause shift issues.
(these tend to cause delays in shifting).


I replaced mine on my 2010 for about $107 in parts... and 5 hrs of my time.
I began to notice delays in shifts. especially Park-- to Drive...
up to 3 seconds for it to engage.
rednox301 and Partzman09 like this.

2013 Equinox LT1 3.6L V6 FWD 88,000
2010 Traverse LT1 3.6L V6 FWD 153,000
2003 Trailblazer LS 4.2L I6 RWD 181,000
rbarrios is offline  
post #3 of 6 (permalink) Old 11-19-2019, 01:58 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,777
Quote:
Originally Posted by Partzman09 View Post
any ideas ? I have my buddy at a chevy dealer pricing me a trans and a TCM...just to be ready...
It's nice to think ahead but I would start with the basics.
Check fluid level, when was the fluid changed last, run a scan for trouble codes, etc etc.
Which engine do you have, AWD ?

Let us know what you find.
Partzman09 likes this.

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013

Last edited by rednox301; 11-19-2019 at 03:37 PM.
rednox301 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 11-19-2019, 03:13 PM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 3
It is awd
Partzman09 is offline  
post #5 of 6 (permalink) Old 11-19-2019, 03:43 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,777
Quote:
Originally Posted by Partzman09 View Post
It is awd
Which engine you have tells us which transmission you have.
Also things like if you have a dipstick to check fluid level.

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013
rednox301 is offline  
post #6 of 6 (permalink) Old 11-21-2019, 12:45 PM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 3
So trans guy doesnt think it is the tranny..
Said : And i quote.. Could be control module circuit voltage below threshold
can bus module (obd2) communication bcm?
Saying it looks like some kind of communication error?
Partzman09 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome