2014 equinox Brake noise - TerrainForum.net: GMC Terrain Forum
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 07-26-2019, 10:35 PM Thread Starter
Jr. Member
 
Join Date: Jul 2019
Posts: 6
2014 equinox Brake noise

Hi, I have a 2014 equinox, when leaving work one day, someone pulled a U turn infront of me causing me to jam on my brakes, ABS kicked in for a second and tires squealed a little, I was going a lot 45mph and just left work so rotors were cold, after that I noticed brakes making a groaning noise when slowing down and it was if the rotors were warped, I brought it in the shop and put new pads and rotors on, and it started making the same noise a day later, so I brought it back in and put the on car lathe on the rotors and could clearly see the brand new rotors spinning and causing the calipers to move back and forth, so I turned the rotors, didn't work still making the same noise, it's my understanding that the hubs on these vehicles rust and swell and cause these rotors to not spin true, am I correct in believing this? I'm going to buy new hubs and rotors and try again, any insight is appreciated
Awakeatground0 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-27-2019, 10:09 AM
Sr. Member
 
repairman54's Avatar
 
Join Date: Sep 2017
Location: Montague, NJ
Posts: 316
Garage
Rust on the hub flange where rotor contacts it by the lug studs is the only hub rust issue that would affect rotor trueness. Solid steel doesn't swell from rust only surface rust on the mounting point will affect trueness.
Check the hub bearings for play, I've had worn bearings warp a rotor and the bearings didn't make any noise. Loose hub bearing caused excessive pad drag warping a new rotor on one of my old Sable's. Pry bar under the tire is my method, too hard to get enough force on the hub without a tire mounted on it. Now I check my bearings when a warped rotor happens along with the caliper pins sticking, binding caliper piston, etc. .

Some suffer from insanity, I choose to enjoy it
'16 nox 3.6 AWD LTZ
'11 Tahoe LTZ
'15 Malibu 2.5 LT
'17 Continental 2.7 TT
'01 FLHR
Ski Doo's
Malibu forum contributor
repairman54 is offline  
post #3 of 8 (permalink) Old 07-27-2019, 09:37 PM Thread Starter
Jr. Member
 
Join Date: Jul 2019
Posts: 6
Thanks for the input, I've already checked both bearings for play(I always check for any play in any part when I have it up in the air) the pins were good, I cleaned and lubed everything, basically did a complete brake service, the only things I can think of is the hubs which I cleaned well, or possibly the screw that holds the rotor to the hub is possibly pulling one side down and raising the other side out, these rotors were after market, but I could see the caliper moving from side to side when I had the lathe on the other rotor, that and I turned both rotors with the on car lathe which should cut them true to how they rotate on the vehicle, there's gotta be rust build up that I missed or something, the crazy part is those hubs didn't even look that bad, I've seen way way worse that I've cleaned and had no issues with, this is just the oddest thing I've had to deal with when it comes to brakes
Awakeatground0 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 07-28-2019, 10:10 AM
Sr. Member
 
repairman54's Avatar
 
Join Date: Sep 2017
Location: Montague, NJ
Posts: 316
Garage
I would say piston is binding in caliper as it should have retracted after enough rotations. Todays plastic pistons swell and a hard brake application could have started it binding. Look at the price of reman. calipers and what the stores have in stock. Cheap and in stock means common usage warranting shelve space. Sticking caliper will warp todays thin rotors quickly. Infra red temp gun points out which one is dragging after a few stops.

Some suffer from insanity, I choose to enjoy it
'16 nox 3.6 AWD LTZ
'11 Tahoe LTZ
'15 Malibu 2.5 LT
'17 Continental 2.7 TT
'01 FLHR
Ski Doo's
Malibu forum contributor
repairman54 is offline  
post #5 of 8 (permalink) Old 07-28-2019, 10:33 AM
Theta Guru
 
Join Date: Feb 2011
Posts: 3,275
Quote:
Originally Posted by repairman54 View Post
Pry bar under the tire is my method, too hard to get enough force on the hub without a tire mounted on it. Now I check my bearings when a warped rotor happens along with the caliper pins sticking, binding caliper piston, etc. .
This is an alternate method to jacking the wheel off the ground, grabbing it at 9 and 3 o’clock, and alternately pushing with the heel of each hand to see how much “play” (or wheel movement) there is?

2011 Equinox 1LT (new Jan 2011): Summit White / 3.0 L V6 / FWD / Pioneer Stereo / 18" Wheels / 138.2k miles [05-NOV-2019]

2002 Impala 1LT (new Jun 2002): Summit White / 3.4 L V6 / FWD / Cassette-CD Combo /225.5k miles [05-NOV-2019]
Colt Hero is offline  
post #6 of 8 (permalink) Old 07-28-2019, 11:58 AM Thread Starter
Jr. Member
 
Join Date: Jul 2019
Posts: 6
I'll definitely look into this as well next time I have it up in the air(hopefully soon) all of my tools are at work, I do know that it showed no signs of the calipers being seized when I changed the brakes, but I know how these things work sometimes, as soon as I figure it out I will post what it was, I was hoping this was a common problem because it has stumped me a little, but no luck there, also, if these new rotors were that warped to begin with then that'll blow my mind because I've never seen rotors warped that badly out of the box, a little maybe and drums as well, but never that bad
Awakeatground0 is offline  
post #7 of 8 (permalink) Old 08-13-2019, 11:54 PM Thread Starter
Jr. Member
 
Join Date: Jul 2019
Posts: 6
Sorry it's been a while, had a day off and checked into everything, turns out that the rotor screw that I put back on that holds the rotor to hub was holding the rotor down against the hub and creating a gap across from it, this was causing the rotors to spin off axis creating a warping effect and also allowing for corrosion to build between the rotor and hub, going to replace the hub assemblies and rotors and pads, the corrosion is too bad to clean properly and even risk putting new rotors on, I will post again if this doesn't fix but it's pretty apparent that this is the issue, also the screws will NOT be on this time around and I'll probably put never seize on the face of the hubs, thanks for all input
Awakeatground0 is offline  
post #8 of 8 (permalink) Old 08-14-2019, 07:13 AM
Theta GOD!
 
Join Date: Jan 2010
Posts: 9,686
Wow, quite a mouthful !

2018 Equinox LT1 1.5 L 4 cyl, AWD, S/R Cajun Red Tintcoat/Black

2010 Equinox LTZ 2.4 L 4 cyl, FWD, S/R Cardinal Red/Black
RIT333 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome