seriously buggy intellilink system in 2014 Terrain Denali - TerrainForum.net: GMC Terrain Forum
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 05-29-2014, 11:32 AM Thread Starter
Jr. Member
 
Join Date: Apr 2011
Posts: 79
seriously buggy intellilink system in 2014 Terrain Denali

So I already have another thread going about problems I'm having related to album artwork, but I didn't want to just add my other problems to that thread so I'm starting a new one here.

I am finding the Intellink system in my 2014 Terrain Denali to be extremely buggy and I'm trying to find out if anyone else is having the same experience. I'll try to explain my issues as best as I can.

Got in the car this morning and was greeted by the following message on the screen for at least the 10th time now - "Download iTunes Tags. Please confirm you would like to download iTunes Tags to: My Video iPod". There are three options for me here - Download, Cancel or Delete All Tags. Not having a clue what's going to happen if I choose Download or Delete, I hit Cancel once again so that I can listen to my ipod (which is connected via USB port). I was listening to it last night on my way home from work so I naturally expected it to pick up right where I left off (listening to a shuffle of my favorite band). My favorite band was indeed playing but for some reason the system was only playing songs from one specific album. Went into the menu and saw that "Shuffle" was unchecked despite the fact that is was checked last night when I was driving home. I have no idea why it can't seem to remember my Shuffle setting and why it decided that it was only going to play songs from one album - I certainly did not tell it to do that.

Frustrated, I switched over to my Bluetooth Audio source (my iphone 5) and started listening to that. Shuffle appears to be working properly there and my favorite band is playing. No more than a few minutes into listening, the music suddenly stops. I look to my screen and sure enough it's displaying "Paused'. Huh? Who paused the music? Certainly not me. This happens constantly and I'm not sure why.

Frustrated once again, I decide to switch over to AM radio to listen to some sports talk. After a few minutes the talking stops. I look to my screen again and see that the radio has decided to switch itself over to Bluetooth audio and the same "Paused" message from before is showing again. What on earth is going on here? Why is my radio switching sources on its own and why is the music constantly pausing anyway?

Then there's the issue I'm having where some album art is not displaying correctly while streaming music from my iphone 5 over bluetooth. I called the Infotainment help line and this is the answer they gave me on that issue:

"Gracenotes operation will change depending on the use of either USB or Bluetooth.
USB - any personal, customer or predetermined (embedded) album art for a song will be used from the device over gracenotes database.
Bluetooth - Gracenotes will take over and display what it feels is appropriate, in some cases we may not have art for an album or artist setup that the customer approves of. There is no way of changing this as the data transfer is not the same as usb."

This answer seems to differ from the answer I was given by some members here who said that Gracenotes only takes over when there is no album art embedded in a song.
psywzrd is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-29-2014, 12:16 PM
Full Member
 
Join Date: Feb 2014
Posts: 127
Re: seriously buggy intellilink system in 2014 Terrain Denali

Quote:
Originally Posted by psywzrd
This answer seems to differ from the answer I was given by some members here who said that Gracenotes only takes over when there is no album art embedded in a song.
That would have been me that said that, based on my experience with a USB drive. Have no experience with using a phone for music, though now that I finally have a Galaxy S3 that may change. some of musical selections do not show ANYTHING from Gracenotes and that may give me pause as to whether or not I'll use my phone as a music source in the Nox. I think I'll be quite happy to just leave it at my USB drive for music.

Some of what you've been experiencing I have encountered as well in my 2013 1LT. My usual source is my USB drive, but it is not always recognized when the car is restarted so the system switches to some other source, be it either AM or FM without seemingly any consistancy as to what it decides to pick. When I then try to manually access the USB drive it says it doesn't recognize the drive so I have to re-plug the drive before it is again recognized, at which point it starts back where it left off when last used.

For me the only time the system does NOT start where left off is when I've had the drive out of the car to make some change, be it playlists or artists, then it starts off from alphabetical artist order.

Never trust anyone without dog hair on their clothes...
2013 1LT FWD I4 Crystal Red w/18" chrome-clad
pieter is offline  
post #3 of 8 (permalink) Old 05-29-2014, 12:26 PM Thread Starter
Jr. Member
 
Join Date: Apr 2011
Posts: 79
Re: seriously buggy intellilink system in 2014 Terrain Denali

@Pieter:

Your reply reminded me of a question I have. How do you eject your USB drive? I can't seem to find the Eject option in the menu system. Do you just pull the drive out of the USB port? My old Terrain had an eject option for my ipod but I see no such option here.

Also, the lack of a Play/Pause button is disappointing. There's more than enough room on the dash for one and God knows the screen is certainly big enough to accommodate one. Why would they have removed that option? Dumb.
psywzrd is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 05-29-2014, 12:56 PM
Theta Guru
 
Join Date: Dec 2010
Posts: 4,923
Re: seriously buggy intellilink system in 2014 Terrain Denali

my 2013 Nox has a play pause button on the dash... use it all the time.

2013 Equinox LT1 3.6L V6 FWD 88,000
2010 Traverse LT1 3.6L V6 FWD 153,000
2003 Trailblazer LS 4.2L I6 RWD 181,000
rbarrios is offline  
post #5 of 8 (permalink) Old 05-29-2014, 04:41 PM
Theta Freak
 
Join Date: Aug 2012
Posts: 1,755
Re: seriously buggy intellilink system in 2014 Terrain Denali

Quote:
Originally Posted by psywzrd

Frustrated, I switched over to my Bluetooth Audio source (my iphone 5) and started listening to that. Shuffle appears to be working properly there and my favorite band is playing. No more than a few minutes into listening, the music suddenly stops. I look to my screen and sure enough it's displaying "Paused'. Huh? Who paused the music? Certainly not me. This happens constantly and I'm not sure why.
On this part, do you stream your music to your phone through iTunes match? Could you have been in a bad network spot? This seems to happen with mine from time to time when up in the mtns.

2012 Equinox 2.4L 1LT AWD, black, 80,000 miles
Ralphalph is offline  
post #6 of 8 (permalink) Old 05-29-2014, 04:43 PM Thread Starter
Jr. Member
 
Join Date: Apr 2011
Posts: 79
Re: seriously buggy intellilink system in 2014 Terrain Denali

Quote:
Originally Posted by Ralphalph
On this part, do you stream your music to your phone through iTunes match? Could you have been in a bad network spot? This seems to happen with mine from time to time when up in the mtns.
Nope - I don't use iTunes match at all. This is all music that is stored locally on my iphone 5.
psywzrd is offline  
post #7 of 8 (permalink) Old 05-29-2014, 07:54 PM
Full Member
 
Join Date: Feb 2014
Posts: 127
Re: seriously buggy intellilink system in 2014 Terrain Denali

Quote:
Originally Posted by psywzrd
Your reply reminded me of a question I have. How do you eject your USB drive? I can't seem to find the Eject option in the menu system. Do you just pull the drive out of the USB port? My old Terrain had an eject option for my ipod but I see no such option here.

Also, the lack of a Play/Pause button is disappointing. There's more than enough room on the dash for one and God knows the screen is certainly big enough to accommodate one. Why would they have removed that option? Dumb.
I just pull it out. The operating system doesn't seems picky about that, unlike Windoze. Certainly on my system (2013 1LT Nox) I have a pause/play button, which I do use very infrequently. I find it very puzzling they've left that off the 2014 Terrain's system, what were they thinking?

Never trust anyone without dog hair on their clothes...
2013 1LT FWD I4 Crystal Red w/18" chrome-clad
pieter is offline  
post #8 of 8 (permalink) Old 05-30-2014, 12:10 AM
Jr. Member
 
Join Date: Aug 2013
Posts: 83
Re:

I've had similar issues recently with my usb drive. First it started playing the same song from the beginning every time the vehicle was started even after pulling the drive out. I've had the terrain for 10 months and haven't had this issue until last week. Had it in for service two days ago and they couldn't find any issues. It also would decide to just play the usb when it felt like it when I was listening to the radio. I'm disappointed with the logic of this system as it doesn't compare to the sync system that ford has. It would be nice if gmc would provide an update for these issues. Another one is the drive shouldn't index every time it's started.

Sent from my SM-G900T using Tapatalk
13terrainguy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome