Locked Infotainment screen-2016 GMC Terrain - Page 2 - TerrainForum.net: GMC Terrain Forum
 4Likes
Reply
 
LinkBack Thread Tools
post #11 of 15 (permalink) Old 10-18-2019, 07:43 PM
Newbie
 
Join Date: Oct 2019
Posts: 1
Quote:
Originally Posted by tizan View Post
The jumping looks like it did something funky to some non-volatile memory which prevented the infotainment system to boot properly... the battery disconnect cleared/erased that memory.

That 2 people reported the same thing after a battery jump in this thread...this must be common.



As these are just the same hardware as a phone or tablet but with a car centric operating system on it...i suspect there is a safe reboot mode to reset the infotainment system...just like holding the power button for more than 10s to force reset a hung tablet or computer or smart-tv.
Thanks for all your suggestions! I have similar problem with radio/info system. Took it in today and Yep the dealer said I need a new/refurbished replacement to the tune of $1,400. plus $350 labor. They said they tried to reboot it and wake it up but to no avail. The interesting thing is I can be driving down the road and it comes on all of a sudden. Once I turn the car off and turn it on again it won't boot up. Sounds like a loose fuse or wire etc. The dealer had to order the part from NY so will have to book another appt. once it comes in. Funny thing it booted up again on the way home so I called the dealer. Response was to wait until over the weekend and see if it still works. I disconnected the negative cable on the battery and waited for 30 minutes...reconnected but it didn't work. Any other suggestions? thanks
Papaack is offline  
Sponsored Links
Advertisement
 
post #12 of 15 (permalink) Old 10-18-2019, 10:18 PM
tic
Full Member
 
Join Date: Aug 2019
Posts: 137
Bang on it a few times? can't hurt at this point
tic is offline  
post #13 of 15 (permalink) Old 10-19-2019, 08:58 PM
Newbie
 
Join Date: Oct 2019
Posts: 4
Our Infotainment system just went out on 2015 Terrain. Haven't taken it to dealer but given all the problems I am thinking aftermarket unit might be best bet?
Atvtrailrider is offline  
Sponsored Links
Advertisement
 
post #14 of 15 (permalink) Old 10-19-2019, 09:06 PM
Newbie
 
Join Date: Oct 2019
Posts: 4
Our Infotainment system just went out on 2015 Terrain. I am thinking aftermarket might be best bet given all the problems I see posted with factory unit.
Atvtrailrider is offline  
post #15 of 15 (permalink) Old 10-20-2019, 01:03 AM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,746
Quote:
Originally Posted by tizan View Post
The jumping looks like it did something funky to some non-volatile memory which prevented the infotainment system to boot properly... the battery disconnect cleared/erased that memory.
I try to avoid jumping a low battery at all costs, I know sometimes it's unavoidable.
When the vehicle with the low battery, and the vehicle with the good battery start, both alternators go wide open.
Hard on the BCM, ECM, etc.

Disconnecting the battery cable to reset one of the modules is a great trick, many times it works with little or no problems.
If you live in a state/county that requires emission testing like I do, the cable disconnecting can cause drive cycle problems.
Just so you know.
Enigma likes this.

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013
rednox301 is offline  
post #16 of 15 (permalink) Old 10-22-2019, 04:31 PM
Jr. Member
 
Join Date: Nov 2018
Posts: 29
Take a look at my post in this section... Sounds like similar issue to what I had. Ended up replacing the radio and having to do some trickery regarding updating the vin in the new radio.


https://www.equinoxforum.net/32-audi...tml#post292191
DenverGp is offline  
post #17 of 15 (permalink) Old 10-22-2019, 10:43 PM
Jr. Member
 
Enigma's Avatar
 
Join Date: Aug 2019
Posts: 89
Any time you may wanna "jump or get jumped" one must make sure the radio is OFF.. This happens a lot on the HHR forum.



And we call fixing it a BCM lobotomy by unhooking the battery terminal & then re connecting it. allow everything to re-boot it self.
Enigma is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome