Has anyone swapped a different year transmission? - TerrainForum.net: GMC Terrain Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 11-14-2019, 11:28 AM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 3
Has anyone swapped a different year transmission?

Hello, has anyone attempted to swap a different year transmission 6t40/45 and use the original tcm? I have a 2011 mh7, and a 2013 mh7 is $300 at junk yard. I show pin location for tcm is the same. I was wondering if anyone has tried 2011 tcm with different year transmission, or just reprogramming junkyard tcm w/transmission to 2011?
mckenzie913 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-14-2019, 03:01 PM
Theta Guru
 
Join Date: Dec 2010
Posts: 4,925
there is a post around here somewhere with that info.

2013 Equinox LT1 3.6L V6 FWD 88,000
2010 Traverse LT1 3.6L V6 FWD 153,000
2003 Trailblazer LS 4.2L I6 RWD 181,000
rbarrios is offline  
post #3 of 5 (permalink) Old 11-14-2019, 09:57 PM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 3
I couldn't find an answer 100% either way. I'm going to pick up the 2013 transmission tomorrow, and hope to have it in by thanksgiving. Going to try the 13 transmission in my 11, and see if I can program the 13 tcm to my vin. If that doesn't work, I will put in the 11 valve body and tcm.
mckenzie913 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 11-30-2019, 12:40 AM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 3
Update on the transmission swap. (I wanted to try a 2013 mh7 transmission because it was $300 with 43k miles, and a 2011 with 100k miles was $1400) swap went good. programmed the tcm, but couldn't do setup because fluid temp sensor showed -40 degrees. tests show faulty tcm/solenoid assy. I used my 2011 valve body and tcm on the 2013 transmission. reset shift adapts, and off i went. almost 100 miles later, shifts great, no codes... all is good. (another reason i got the 2013 transmission, is that if it didn't work, my daughter has a 2013 equinox with that transmission in case she ever needed it)
mckenzie913 is offline  
post #5 of 5 (permalink) Old 11-30-2019, 01:43 AM
Theta Guru
 
Join Date: Feb 2011
Posts: 3,348
Congrats! And another good data point here, but could it have been the valve body and TCM all along?

2011 Equinox 1LT (new Jan 2011): Summit White / 3.0 L V6 / FWD / Pioneer Stereo / 18" Wheels / 138.2k miles [05-NOV-2019]

2002 Impala 1LT (new Jun 2002): Summit White / 3.4 L V6 / FWD / Cassette-CD Combo /225.5k miles [05-NOV-2019]
Colt Hero is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome