2017 Equinox Heated Seats Not Working - TerrainForum.net: GMC Terrain Forum
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 10-09-2019, 08:56 PM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 4
2017 Equinox Heated Seats Not Working

My wife noticed today that her heated seats are not working in her 2017 Equinox and of course she just went over the 36,000mi warranty mark. I looked through all the fuses (#51, 25A) and made sure all the connections were tight and connected. No wires seem to be nicked or exposed and grounding out. Is there anything else I should be looking for? Neither button will not light up, but everything else works as far as I can tell on the instrument panel.


I did a search from previous posts and some point to a GM controller. Not sure if I would just replace that and see or take it to the dealer to find out whats going on.


Thanks
Bob
Blymanb is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 10-09-2019, 10:26 PM
Theta GOD!
 
Join Date: Jan 2010
Posts: 9,648
Depending on cost, I'd probably throw in a controller.

2018 Equinox LT1 1.5 L 4 cyl, AWD, S/R Cajun Red Tintcoat/Black

2010 Equinox LTZ 2.4 L 4 cyl, FWD, S/R Cardinal Red/Black
RIT333 is offline  
post #3 of 9 (permalink) Old 10-10-2019, 04:58 PM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 4
Its $95 on Amazon...probably triple at the dealership.
Blymanb is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 10-10-2019, 07:21 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,754
I have the info for the 2014 Nox heated seats.
My guess is the 2017 is different.

If you have the LTZ then you get the Seat Memory Option with the Heated Seat Option on the 2014.
That means you get two controllers, the Heated Seat Control Module and the Seat Memory Control Module.
The heated seats uses both controllers.

Do you have the seat memory option?
You may have to find a 2017 wiring diagram to verify this.

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013

Last edited by rednox301; 10-11-2019 at 11:40 AM.
rednox301 is offline  
post #5 of 9 (permalink) Old 10-11-2019, 08:45 AM
Full Member
 
Join Date: May 2017
Posts: 170
If you just went over the 36000kmi mark, perhaps you might catch them on a good day and get warranty still ? Can't hurt to ask
probak118 is offline  
post #6 of 9 (permalink) Old 10-11-2019, 08:46 AM
Full Member
 
Join Date: May 2017
Posts: 170
If you just went over the 36000 miles mark, perhaps you might catch them on a good day and get warranty still ? Can't hurt to ask
probak118 is offline  
post #7 of 9 (permalink) Old 10-11-2019, 01:08 PM
Jr. Member
 
Join Date: Sep 2018
Posts: 6
I had the same thing happen to my 2013. I did exactly as you did...checked wires, connectors and fuses. I remember someone saying since it's a controller and not a physical on/off setup, they recommended unhooking the battery and let it reset. Well, it worked. It was worth the trouble of having to reset the radio, etc. as opposed to paying for a new controller. Sometimes simple works.
lotusman91 is offline  
post #8 of 9 (permalink) Old 10-12-2019, 02:11 PM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 4
Quote:
Originally Posted by rednox301 View Post
I have the info for the 2014 Nox heated seats.
My guess is the 2017 is different.

If you have the LTZ then you get the Seat Memory Option with the Heated Seat Option on the 2014.
That means you get two controllers, the Heated Seat Control Module and the Seat Memory Control Module.
The heated seats uses both controllers.

Do you have the seat memory option?
You may have to find a 2017 wiring diagram to verify this.
Its not an LTZ and she does not have seat memory.
Blymanb is offline  
post #9 of 9 (permalink) Old 10-12-2019, 02:12 PM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 4
Quote:
Originally Posted by lotusman91 View Post
I had the same thing happen to my 2013. I did exactly as you did...checked wires, connectors and fuses. I remember someone saying since it's a controller and not a physical on/off setup, they recommended unhooking the battery and let it reset. Well, it worked. It was worth the trouble of having to reset the radio, etc. as opposed to paying for a new controller. Sometimes simple works.
I'll give that a try today. I've checked over everything and can't find any other issues.
Blymanb is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome