2019 Vibration in steering wheel. - Page 2 - TerrainForum.net: GMC Terrain Forum
 1Likes
Reply
 
LinkBack Thread Tools
post #11 of 16 (permalink) Old 07-31-2019, 06:19 AM Thread Starter
Jr. Member
 
Join Date: Jul 2019
Posts: 7
It's kind of a shame that GM made some of these decisions with the new Equinox all for the sake of fuel economy. Honestly I didn't put much thought into gas mileage when it came to purchasing an suv. I would have rather gm done a better job with some of these querks people are experiencing. You shouldn't have to put the trans into a lower gear to avoid a vibration that shouldn't have been there to begin with.
c&wsinbad likes this.
DarkGnome is offline  
Sponsored Links
Advertisement
 
post #12 of 16 (permalink) Old 07-31-2019, 11:46 PM
Sr. Member
 
garbec01's Avatar
 
Join Date: Jan 2011
Location: Cambridge IL - USA
Posts: 306
Garage
Quote:
Originally Posted by Juli View Post
Noticed this in my 2.0 Diesel. .
Your Equinox, if equipped with the diesel engine has a displacement of 1.6 liters; the 1.5 and 2.0 are the gas engine options. All are direct injected and turbocharged four cylinder engines.

The diesel engine option, unfortunately has been discontinued for the 2020 model year.

.

2019 Chevy Equinox; 2.0 - LT - FWD - Silver Ice/Redline - Purchased 10/20/2018; Mills Chevrolet, Davenport IA
2016 Chevy Equinox; 3.6 - LTZ-AWD - Black/Black - Purchased 7/7/2016; Mills Chevrolet, Davenport IA
2017 Chevy Malibu; 1.5 - LT - Pepperdust - Purchased 8/2017; Green Chevrolet, East Moline, IL
2009 Chevy Silverado; 5.3 -LT - 4WD - Ext. Cab - Granite Met. - Purchased 02/2009; Green Chevrolet, East Moline IL
garbec01 is online now  
post #13 of 16 (permalink) Old 08-01-2019, 03:47 PM
Jr. Member
 
17 Nox's Avatar
 
Join Date: Sep 2017
Posts: 75
Try turning off or on the ECO mode. I noticed this happening in my 2017 2.4. It does not do it out of ECO mode.
17 Nox is offline  
Sponsored Links
Advertisement
 
post #14 of 16 (permalink) Old 08-01-2019, 05:29 PM Thread Starter
Jr. Member
 
Join Date: Jul 2019
Posts: 7
Quote:
Originally Posted by 17 Nox View Post
Try turning off or on the ECO mode. I noticed this happening in my 2017 2.4. It does not do it out of ECO mode.
I don't believe we have an ECO mode? I looked through all the options and a button. Could not find anything.
DarkGnome is offline  
post #15 of 16 (permalink) Old 08-01-2019, 05:55 PM
Sr. Member
 
Join Date: May 2017
Posts: 483
Quote:
Originally Posted by DarkGnome View Post
I don't believe we have an ECO mode? I looked through all the options and a button. Could not find anything.


we donít, eco mode stopped after 2017


Sent from my iPhone using Tapatalk
kastner03 is offline  
post #16 of 16 (permalink) Old 08-01-2019, 08:08 PM
Jr. Member
 
17 Nox's Avatar
 
Join Date: Sep 2017
Posts: 75
Sorry, I did not know they discontinued after 2017. My mistake.
17 Nox is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome