HVAC Questions - TerrainForum.net: GMC Terrain Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 03-29-2019, 09:16 PM Thread Starter
Jr. Member
 
Join Date: Jul 2018
Location: Taos, NM
Posts: 58
Question HVAC Questions

I've been wondering if the HVAC system fails from time to time. All winter I had the A/C off and tied to run the heater and defroster often. The heater usually works for a while and then starts blowing "cool" air so then I crank up the temperature from, say 72, to 82 and it starts heating again... of course the blower speed stays low so I have to adjust that as well. The defroster kinda does the same thing but I bump up the fan speed to max as more and more snow falls.

Now, the weather warming, I have to use the A/C and now the opposite happens... at first it will cool OK with the temp set at 71 but then, after a while, I have to crank the temp setting to 60 to get any cool air and turn up the blower speed to get cool air moving.

I tried "auto" and that helps for a short while but not really great.

I took it in for service and was told "it's all normal"... Hard to believe this is normal! Our 12 year old Fusion does better.

Maybe I'm missing something?
taoshum is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-29-2019, 11:00 PM
Theta GOD!
 
Join Date: Jan 2010
Posts: 9,686
My '10 did funky stuff like that. I didn't like it, but I accepted it. I suspect it is working as it is "supposed to".

2018 Equinox LT1 1.5 L 4 cyl, AWD, S/R Cajun Red Tintcoat/Black

2010 Equinox LTZ 2.4 L 4 cyl, FWD, S/R Cardinal Red/Black
RIT333 is offline  
post #3 of 3 (permalink) Old 03-30-2019, 01:46 PM
Sr. Member
 
Join Date: May 2017
Posts: 491
HVAC Questions

Quote:
Originally Posted by taoshum View Post
I've been wondering if the HVAC system fails from time to time. All winter I had the A/C off and tied to run the heater and defroster often. The heater usually works for a while and then starts blowing "cool" air so then I crank up the temperature from, say 72, to 82 and it starts heating again... of course the blower speed stays low so I have to adjust that as well. The defroster kinda does the same thing but I bump up the fan speed to max as more and more snow falls.



Now, the weather warming, I have to use the A/C and now the opposite happens... at first it will cool OK with the temp set at 71 but then, after a while, I have to crank the temp setting to 60 to get any cool air and turn up the blower speed to get cool air moving.



I tried "auto" and that helps for a short while but not really great.



I took it in for service and was told "it's all normal"... Hard to believe this is normal! Our 12 year old Fusion does better.



Maybe I'm missing something?


it must be subjective to each owner being pleased with it, my Ď15 and 18 both work great... i may have touched the climate control 5 times max over the whole winter... mainly to use the max defrost feature if i had parked outside. my dad and sister both had fusions... one was a 11 and one a 13 i believe and i hated the climate control in both... i found it crazy that ďauto climate control ď was a premium option yet you constantly had to mess with it to be comfortable... nothing really automatic about it. one thing i will say i noticed when i got my Ď18 is that i had to set the temp about 4 degrees warmer than i always kept it in my Ď15 but once it was set i normally donít need to touch it. i set it to floor/defrost and around 74 degrees and iím comfortable most of the winter with the fan on auto


Sent from my iPhone using Tapatalk
kastner03 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome