Service Stabilitrak service power steering - TerrainForum.net: GMC Terrain Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-25-2019, 08:24 PM Thread Starter
Newbie
 
Join Date: Jun 2019
Posts: 2
Service Stabilitrak service power steering

For the last couple months we have been getting a service stabilitrak servjce power steering on the driver info center. The power steering stops working. The ABS light comes on as well as the traction control light.

The kicker is it typically does it when we back out of the driveway and turn the wheel slightly. It’s almost like it gets to a point then kicks on there errors. If you drive a couple miles and restart the car it may not pop back on.

The dealership said it’s the electronic break control module. I’m not sold on that although I did buy a new one and plan to go ahead and replace my wheel bearings.

Any suggestions on what this could be?

2010 AWD 6.0 167k miles
Cw7174 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome