Service battery charging system and batt light on - TerrainForum.net: GMC Terrain Forum
Reply
 
LinkBack Thread Tools
post #1 of 17 (permalink) Old 02-23-2017, 12:21 PM Thread Starter
Jr. Member
 
Join Date: Sep 2016
Posts: 8
Service battery charging system and batt light on

I got a 2011 chevy equinox 2.4 has a new alternator and battery it's charging right but service battery charging system message come on and batt light on . Please help already tried what I could and still on . Thanks
Chito_Lp is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 02-23-2017, 12:28 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,036
Re: Service battery charging system and batt light on

Quote:
Originally Posted by Chito_Lp
I got a 2011 chevy equinox 2.4 has a new alternator and battery it's charging right but service battery charging system message come on and batt light on . Please help already tried what I could and still on . Thanks
If you have a new battery and alternator and clean cables, check with a volt meter.
You should read about 14.4 to 14.8 volts at idle.

As far as the battery light you might still have a previous trouble code in memory that was not cleared after the work you did.
Have you tried to jump start another vehicle?

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013
rednox301 is offline  
post #3 of 17 (permalink) Old 02-23-2017, 12:40 PM Thread Starter
Jr. Member
 
Join Date: Sep 2016
Posts: 8
Re: Service battery charging system and batt light on

Ok I've checked with volt meter and at idle it's throwing out 13.5 13.6 so what should I check next ?
Chito_Lp is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 02-23-2017, 12:55 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,036
Re: Service battery charging system and batt light on

Your alternator is charging but I think that is low.
It depends on the state of charge of the battery.

Give the alternator a load, turn on the high beam headlights, A/C fan on high, etc. and rev up engine to approx 1,500 RPM's.
Check the voltage again.

Next I would go to the belt, two fuses, tensioner, and check for trouble codes.

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013
rednox301 is offline  
post #5 of 17 (permalink) Old 02-23-2017, 01:01 PM Thread Starter
Jr. Member
 
Join Date: Sep 2016
Posts: 8
Re: Service battery charging system and batt light on

Should I put a charger on the battery to see if there's a difference ?
Chito_Lp is offline  
post #6 of 17 (permalink) Old 02-23-2017, 01:04 PM
Theta Freak
 
rednox301's Avatar
 
Join Date: Nov 2014
Posts: 1,036
Re: Service battery charging system and batt light on

No, I'm trying to see if your alternator will put out more with a load.

2014 Equinox LTZ FWD 3.6L. V-6 (LFX)
GM6T70 Transmission-Gen II(M7W)
Crystal Red Tintcoat-Brownstone Leather-(FE2) Suspension-18" Wheels
Build Date: Nov. 04, 2013-Delivery Date: Nov. 25, 2013
rednox301 is offline  
post #7 of 17 (permalink) Old 02-23-2017, 01:08 PM Thread Starter
Jr. Member
 
Join Date: Sep 2016
Posts: 8
Re: Service battery charging system and batt light on

Ok will try that
Chito_Lp is offline  
post #8 of 17 (permalink) Old 02-23-2017, 01:11 PM
Theta Guru
 
Join Date: Dec 2010
Posts: 3,991
Re: Service battery charging system and batt light on

the I4 should be the same.

but on the 3.6 (Traverse/ACadia with a voltmeter on the dash) and the 3.6 Equinox(with no voltmeter), the alternator is controlled by the computer.
If the batt is fully charged, and no load- the alternator output is lowered.
if there is load (AC, defroster, seat heater) the voltage is ramped up.

Folks on the Traverse/Lambda forums always ask-- why is my voltage gauge showing around 13V sometimes---- other times its 15 V.

well - its the computer doing its thing- based on batt charge- and electrical load- that will result in what the alternator puts out.

just an fyi- as to why hes asking for you to turn on loads.

2013 Equinox&nbsp; LT1 3.6L V6 FWD -&nbsp; &nbsp;60,000<br />2010 Traverse LT1 3.6L V6 FWD -&nbsp;127,000 <br />2003 Trailblazer LS&nbsp; 4.2L I6 RWD- 180,000
rbarrios is offline  
post #9 of 17 (permalink) Old 02-23-2017, 01:16 PM Thread Starter
Jr. Member
 
Join Date: Sep 2016
Posts: 8
Re: Service battery charging system and batt light on

Thanks
Chito_Lp is offline  
post #10 of 17 (permalink) Old 02-24-2017, 04:19 PM Thread Starter
Jr. Member
 
Join Date: Sep 2016
Posts: 8
Re: Service battery charging system and batt light on

So I did put a load last night and it stays at a constant 13.5 volts I put the battery charger on the battery all night and this morning checked it again and still same situation . Any idea ?
Chito_Lp is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome