Air conditioning only blows at feet and defrost Chevy Equinox 2013 - TerrainForum.net: GMC Terrain Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 06-11-2017, 01:46 PM Thread Starter
Newbie
 
Join Date: Jun 2017
Posts: 2
Air conditioning only blows at feet and defrost Chevy Equinox 2013

Im guess a blend door actuator or valve ? Im wondering how many blend doors it has, and there location.

Thanks!!
noacktexas is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-11-2017, 08:49 PM
Theta Guru
 
JayTee2014's Avatar
 
Join Date: Sep 2014
Posts: 3,496
Re: Air conditioning only blows at feet and defrost Chevy Equinox 2013

There is only ONE Blend Door. It routes or allows EITHER HOT air from the heater core OR COLD AIR from the AC coil to flow through the HVAC system.
There is a MODE DOOR that is just above the BLEND DOOR a bit, and it controls and routes air either to the Defrost/Floor vents OR to the UPPER Front Dash vents above the radio.

So it sounds more like your Mode Door. The Mode Door actuator is on the Left side of the Center Control Stack and the Blend Door actuator is on the Right side.

Do some searches here using the SEARCH BOX upper right for Mode Door. .. .. Lots of info here if you do the leg work. . . complete with pictures and hints on how to diagnose and repair.

<br />2015 Equinox LTZ 3.6L FWD Champagne Silver Metallic *Build Date 1-08-2015&nbsp; * * 20,300 miles
JayTee2014 is offline  
post #3 of 4 (permalink) Old 06-11-2017, 09:34 PM Thread Starter
Newbie
 
Join Date: Jun 2017
Posts: 2
Re: Air conditioning only blows at feet and defrost Chevy Equinox 2013

Thank you for the info Jay! Really appreciate the info!
noacktexas is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-16-2017, 09:17 AM
Jr. Member
 
Join Date: Jun 2017
Posts: 6
I had an issue that started like this with a 2013 Charger.
I forget the details because there are so many, but it started IIRC with blowing hot air with the AC on. It could have been hot at one level and cold at another.

Dealer said blend door. Mechanic with long skinny fingers repaired.

Same stuff kept happening, the car went in eight times as the situation replicated in one form or another. THEN the radio/screen got involved, they said it was a major wire that went from the dashboard control gizmo to the computer. I should have Lemon Law'd the car but I ditched it instead.

Hopefully your issue doesn't expand this far. It sucked having the car in every couple of weeks for something new.
Neanderthal is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TerrainForum.net: GMC Terrain Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome